Node Modules versiyon uyuşmazlığı (gulp build sorunu)

Standard

Merhaba Arkadaşlar;

Node Js ile yeni yeni proje geliştirirken ilginç bir durum fark ettim. Yeni başlayan arkadaşlar da faydalanır düşüncesi ile sizinle de paylaşıyorum.

Örneğin daha önce Gulp.js ile derlenmiş (build edilmiş) bir projede bilgisayarda ki nodejs versiyonu değiştiğinde (genellikle update edildiğinde) eski sürüm ile gelen nodejs modülleri bir sonraki build işlemlerinizde hata verebiliyor ve hatta zaman zaman bazı durumlarda build işlemini gerçekleştiremiyor. Benim de çözmek için çok uzun zamanımı alan bu durumu fark edip biraz araştırdığımda aşağıdaki çözüme ulaştım. Benim için çalıştı bir sorun ile karşılaşmadım. Umarım size de faydası olur.
1. Çözüm:
Sırası ile uygulanması gereken adımlar;
npm install -g salita
satila package.json dosyanızda ki sürümleri güncelleyecektir.
npm update --save
Eğer --save kısmını eklemezseniz çok fazla uzun sürebiliyor güncelleme işlemi ve hatta donup kalma olasılığı var.
Bu işlem biraz zaman alabiliyor. Sabretmelisiniz.

2. Çözüm:
1. Çözüm sonrasında libsass bindings not found gibi bir mesaj alırsanız eğer node-sass güncellenmesi ya da yeniden kurulması gerekir.
Bu işlem için aşağıdaki adımları deneyin.

npm install node-sass
ya da

npm uninstall node-sass
npm install node-sass

3. Çözüm:
Eğer yukarıdaki işlem sizin için çözüm olmaz ise alternatif yol olarak aşağıdaki çözümü uygulayabilirsiniz.
1. package.json dosyanızda gulp-sass için kullanacağınız versiyonu aşağıdaki şekilde belirtin.

"devDependencies" {
"gulp-sass":"*"
}

2. Projenizdeki node_modules dizinini siliyoruz.

cd [proje ana dizini] &&
rm -rf node_modules/

3. npm güncelliyoruz.
npm update

Şu andan itibaren npm ve node modülleri tamamen yeni versiyona göre ayarlanmış oldu. Artık gulp build diyebiliriz.